package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.\d*?[1-9])0+$`)
var str = `0.24000
4.1100
200
0.100
1.0
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}