re = /^(\d+\.\d*?[1-9])0+$/m
str = '0.24000
4.1100
200
0.100
1.0
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result