package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\S.*(?:\r?\n\S.*)*$`)
var str = `1 2 3
4 5 6
7 8 999`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}