$re = '/^\S.*(?:\r?\n\S.*)*$/u';
$str = '1 2 3
4 5 6
7 8 999';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);