package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[a-z]+$`)
var str = `abCde
ABCde
abcDe3
aSc#-er
ABCDE_
ABE_Ed`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}