$re = '/^[a-z]+$/im';
$str = 'abCde
ABCde
abcDe3
aSc#-er
ABCDE_
ABE_Ed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);