re = /([^\\]+)(?:\.exe)/
str = '\\"D:\\\\src\\\\repos\\\\myprj\\\\bin\\\\Debug\\\\MyApp.exe\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end