# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(add|and|nor|or|sub)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4})\s*$"
test_str = ("add $t3,$s3,$s5\n"
"add $t3,$s3,$s5\n"
"add $v0,$t0,$t0\n"
"add $v0,$t0,$t0\n"
"and $t2,$t3,$t4\n"
"and $t2,$t3,$t4\n"
"nor $s0,$s5,$s2\n"
"nor $s0,$s5,$s2\n"
"or $s0,$s0,$s1\n"
"or $s0,$s0,$s1\n"
"or $s0,$s2,$s5\n"
"or $s0,$s2,$s5\n"
"sub $s3,$t0,$t1\n"
"sub $s3,$t0,$t1\n"
"sub $t0,$zero,$t1\n"
"sub $t0,$zero,$t1\n"
"sub $t1,$t4,$t8\n"
"sub $t1,$t4,$t8")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.