// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(add|and|nor|or|sub)\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4}),\s*(\$[a-z0-9]{2,4})\s*$").unwrap();
let string = "add $t3,$s3,$s5
add $t3,$s3,$s5
add $v0,$t0,$t0
add $v0,$t0,$t0
and $t2,$t3,$t4
and $t2,$t3,$t4
nor $s0,$s5,$s2
nor $s0,$s5,$s2
or $s0,$s0,$s1
or $s0,$s0,$s1
or $s0,$s2,$s5
or $s0,$s2,$s5
sub $s3,$t0,$t1
sub $s3,$t0,$t1
sub $t0,$zero,$t1
sub $t0,$zero,$t1
sub $t1,$t4,$t8
sub $t1,$t4,$t8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}