import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^(.{20})[^.]*(?:(\\.)((?(2).*?)))*$";
        final String string = "1.1234567890.ab\n"
	 + "2.123456789012345678901.ab\n"
	 + "3.1234567890123456789012.ab\n"
	 + "4.12345678901234567890123.ab\n"
	 + "5.123456789012345678901234.ab\n"
	 + "6.1234567890123456789012345.ab\n"
	 + "7.12345678901234567890123456.ab\n"
	 + "8.123456789012345678901234567890.ab\n"
	 + "9.123456789012345678901234567890.1234567890123456.7890.ab\n"
	 + "0.123456789012345678901234567890.12345678901.234567890....abcdef012345\n"
	 + "  12345678901234567890123456789012345678901234567890";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}