# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.{20})[^.]*(?:(\.)((?(2).*?)))*$"
test_str = ("1.1234567890.ab\n"
"2.123456789012345678901.ab\n"
"3.1234567890123456789012.ab\n"
"4.12345678901234567890123.ab\n"
"5.123456789012345678901234.ab\n"
"6.1234567890123456789012345.ab\n"
"7.12345678901234567890123456.ab\n"
"8.123456789012345678901234567890.ab\n"
"9.123456789012345678901234567890.1234567890123456.7890.ab\n"
"0.123456789012345678901234567890.12345678901.234567890....abcdef012345\n"
" 12345678901234567890123456789012345678901234567890")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.