package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w0-9\.-]*@college\.edu`)
var str = `mark@college.edu
mark@university.edu
harry@college.edu
m-example@college.edu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}