$re = '/[\w0-9\.-]*@college\.edu/';
$str = 'mark@college.edu
mark@university.edu
harry@college.edu
m-example@college.edu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);