$re = '/(?:group_)?concat\(([^)]+)\)(?R)?/i';
$str = 'concat(first_name, \' \', last_name) concat(first_name, \' \', last_name) concat(first_name, \' \', last_name)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);