re = /(?:group_)?concat\(([^)]+)\)(?R)?/i
str = 'concat(first_name, \' \', last_name) concat(first_name, \' \', last_name) concat(first_name, \' \', last_name)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end