re = /^0[.\(\/]5[0-9][0-9][.\)\/][.\ \/][1-9]([0-9]){2}[.\-\/]([0-9]){4}$/
str = '0(545) 355-1531'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result