#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(droit au bail|DAB)\s?(\W|du|de|fix[eé] [aà]|[aà]|est de)? (\d+.\d+|\d+\s\d+)"
Local $sString = "[DROIT AU BAIL]" & @CRLF & _
"" & @CRLF & _
"droit au bail de 100000 € " & @CRLF & _
"droit au bail : 100 000€ " & @CRLF & _
"droit au bail à 150 000 € " & @CRLF & _
"droit au bail 102000€ " & @CRLF & _
"droit au bail = 200.000 € " & @CRLF & _
"droit au bail fixé à 200000 € " & @CRLF & _
"droit au bail fixé à 200000 EUR" & @CRLF & _
"droit au bail fixé à 200000 euro" & @CRLF & _
"droit au bail : nous consulter " & @CRLF & _
"Prix DAB : 230 000 euros net vendeur" & @CRLF & _
"DAB : 100 000 euros HD" & @CRLF & _
"Prix DAB : 26 000 euros honoraires à charge vendeur" & @CRLF & _
"Cession du droit au bail : 100 000 euros FAI" & @CRLF & _
" Prix de cession du droit au bail : 298.000euros honoraires charge vendeur." & @CRLF & _
"la cession du droit au bail est de 85 000 euros Hors Honoraires" & @CRLF & _
"cession de droit au bail de 23 000€ net vendeur" & @CRLF & _
"droit au bail 62 000 euros" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")