import re
regex = re.compile(r"(droit au bail|DAB)\s?(\W|du|de|fix[eé] [aà]|[aà]|est de)? (\d+.\d+|\d+\s\d+)", flags=re.MULTILINE)
test_str = ("[DROIT AU BAIL]\n\n"
"droit au bail de 100000 € \n"
"droit au bail : 100 000€ \n"
"droit au bail à 150 000 € \n"
"droit au bail 102000€ \n"
"droit au bail = 200.000 € \n"
"droit au bail fixé à 200000 € \n"
"droit au bail fixé à 200000 EUR\n"
"droit au bail fixé à 200000 euro\n"
"droit au bail : nous consulter \n"
"Prix DAB : 230 000 euros net vendeur\n"
"DAB : 100 000 euros HD\n"
"Prix DAB : 26 000 euros honoraires à charge vendeur\n"
"Cession du droit au bail : 100 000 euros FAI\n"
" Prix de cession du droit au bail : 298.000euros honoraires charge vendeur.\n"
"la cession du droit au bail est de 85 000 euros Hors Honoraires\n"
"cession de droit au bail de 23 000€ net vendeur\n"
"droit au bail 62 000 euros\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")