$re = '/(?>[a-zA-Z]{1}:\\\\)(.*)(?>\\\\.+\..+)/m';
$str = 'c:\\foo\\bar\\baz.txt
C:\\FOO\\BAR\\BAZ.TXT
C:\\FoO\\BaR\\BaZ.TxT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);