re = /(?>[a-zA-Z]{1}:\\)(.*)(?>\\.+\..+)/m
str = 'c:\\foo\\bar\\baz.txt
C:\\FOO\\BAR\\BAZ.TXT
C:\\FoO\\BaR\\BaZ.TxT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end