package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[^0])0{3}([^0]|$)`)
var str = `0//////0/00/ LS///////000
000////0/00/ LS//////////
0//////0/00/ LS////000///
0//////000// LS//////000/
0//////000// LS//00000000
but not:
0//////0000/ LS//////////
0//////0000/ LS//////////
0/////00000/ LS//////////`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}