import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^0])0{3}([^0]|$)";
final String string = "0//////0/00/ LS///////000\n"
+ "000////0/00/ LS//////////\n"
+ "0//////0/00/ LS////000///\n"
+ "0//////000// LS//////000/\n"
+ "0//////000// LS//00000000\n"
+ "but not:\n\n"
+ "0//////0000/ LS//////////\n"
+ "0//////0000/ LS//////////\n"
+ "0/////00000/ LS//////////";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}