import re
regex = re.compile(r"(?P<before>(?:(?!\[download=\"[^\"]*\" type=\"[^\"]*\"\]).)*)\[download=\"(?P<download>[^\"]*)\" type=\"(?P<type>[^\"]*)\"\](?P<after>(?:(?!\[download=\"[^\"]*\" type=\"[^\"]*\"\]).)*)")
test_str = "text here [download=\"PDC\" type=\"A\"] and the text continues [download=\"PDS\" type=\"B\"] and more text yet again, more shotcodes might exist ..."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")