package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?'range'\d+(-\d+)?),\s*)*((?&range)\s*)$`)
var str = `10-12, 6, 50-56
12
12-12
12-6, 2
12-6, 2-2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}