$re = '/^((?\'range\'\d+(-\d+)?),\s*)*((?&range)\s*)$/m';
$str = '10-12, 6, 50-56
12
12-12
12-6, 2
12-6, 2-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);