import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(name|date|location)(?:\\s*([<>:]{1,2})(?:\\s*))((?:(?!\\b(?:and|or)\\b).)+)(?:\\b(and|or)\\b)?";
final String string = "name: jill, joe, !john or date: today, yesterorday and location: location1, location2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}