using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[\s\p{P}])\K\p{L}";
string input = @"abcdefgh ijklmnop ""qrstuvwx"" yzéâäàåç êëèïîìæô öòûùÿáíóúñ
ABCDEFGH IJKLMNOP QRSTUVWX YZÉÂÄÀÅÇ ""ÊËÈÏÎÌÆÔ"" ÖÒÛÙŸÁÍÓÚÑ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}