$re = '/#([^\"|\'][\S]+)|#[\"]{1}([^"]+)[\"]{1}|#[\']{1}([^\']+)[\']{1}/mi';
$str = 'Ñ‚Ð²Ð¾Ñ #погода1 ÐºÐ°ÐºÐ°Ñ Ð¿Ñ€ÐµÐºÑ€Ð°ÑÐ½Ð°Ñ #погода1 или же нет #"хорошей погоды" завтра #погода1 как вÑегда #хорошей погоды и Ñ Ð¿Ð¾Ð¼Ð¾Ñ‰ÑŒÑŽ #\'золотого днÑ\' ÑегоднÑ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);