$re = '/^5[1-5]\d{14}$|^2(?:2(?:2[1-9]|[3-9]\d)|[3-6]\d\d|7(?:[01]\d|20))\d{12}$/m';
$str = '1221009999999999
2121009999999999
2211009999999999
2220009999999999
2221009999999999
2321009999999999
2499999999999999
2720999999999999
2721009999999999
2721999999999999
2730999999999999
2820999999999999
4111111111111111
5055555555555555
5100000000000000
5255555555555555
5444444444444444
5555555555555555
5600000000000000
5911111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);