# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^5[1-5]\d{14}$|^2(?:2(?:2[1-9]|[3-9]\d)|[3-6]\d\d|7(?:[01]\d|20))\d{12}$"
test_str = ("1221009999999999\n"
"2121009999999999\n"
"2211009999999999\n"
"2220009999999999\n"
"2221009999999999\n"
"2321009999999999\n"
"2499999999999999\n"
"2720999999999999\n"
"2721009999999999\n"
"2721999999999999\n"
"2730999999999999\n"
"2820999999999999\n"
"4111111111111111\n"
"5055555555555555\n"
"5100000000000000\n"
"5255555555555555\n"
"5444444444444444\n"
"5555555555555555\n"
"5600000000000000\n"
"5911111111111111")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.