$re = '/(?:^|\G)\s*"?((?<=")(?:\\\\.|[^\n"\\\\])*(?=")|(?<!")[^\n",]+(?<!\s))"?\s*(?:,|$)/m';
$str = 'a,b,"c,d,e
"this_item,should,not,match
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);