re = /(?:^|\G)\s*"?((?<=")(?:\\.|[^\n"\\])*(?=")|(?<!")[^\n",]+(?<!\s))"?\s*(?:,|$)/m
str = 'a,b,"c,d,e
"this_item,should,not,match
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end