package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:http\:\/\/(?:www\.)?){1}[^\/]*\/([^\/]*)(?#parameter2)(?:\/([^\/]*))?(?#parameter3)(?:\/([^\/]*))?(?#parameter4)(?:\/([^\/]*))?`)
var str = `http://localhost/asd/asd/asd/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}