re = /mver=\K\d+/
str = '"/maze/action.xml?mver=66381&cid=474&melu=0&osName=Windows%208&dbv=38&ucnt=19
"/maze/action.xml?mver=66381'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end