# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b.+?\b)\1\b/\1/g;t' <<< "are blue and then and then more and then and then more very bright"