#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\*([^\s*]+(?:\s+[^\s*]+)*)\*"
Local $sString = "*t* -> match ok" & @CRLF & _
"*test and test* -> match ok" & @CRLF & _
"* test and test* -> match NOT ok" & @CRLF & _
"*test and test * -> match NOT ok" & @CRLF & _
"* test and test * -> match NOT ok"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")