re = /\*([^\s*]+(?:\s+[^\s*]+)*)\*/m
str = '*t* -> match ok
*test and test* -> match ok
* test and test* -> match NOT ok
*test and test * -> match NOT ok
* test and test * -> match NOT ok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end