package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0-9]+(?:\n[0-9]+)*$`)
var str = `123a
345
678
9752`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}