$re = '/^[0-9]+(?:\n[0-9]+)*$/';
$str = '123a
345
678
9752';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);