using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!325([0-2][0-9]|3[0-2])|65535)^[1-5][0-9]{0,4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-4]$";
string input = @"0
1
2
100
32448
32500
32501
32531
32532
32533
59999
60000
60999
63999
64999
65000
64599
65534
65535";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}