$re = '/(?!325([0-2][0-9]|3[0-2])|65535)^[1-5][0-9]{0,4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-4]$/m';
$str = '0
1
2
100
32448
32500
32501
32531
32532
32533
59999
60000
60999
63999
64999
65000
64599
65534
65535';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);