#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:youtube\.com.*(?:\?|&)(?:v|list)=|youtube\.com.*embed\/|youtube\.com.*v\/|youtu\.be\/)((?!videoseries)[a-zA-Z0-9_]*)"
Local $sString = "https://www.youtube.com/watch?v=fqMfRi2gJok&index=1&list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r" & @CRLF & _
"https://www.youtube.com/watch?v=fqMfRi2gJok" & @CRLF & _
"http://youtu.be/cCnrX1w5luM " & @CRLF & _
"http://youtube.com/embed/cCnrX1w5luM" & @CRLF & _
"http://youtube.com/v/cCnrX1w5luM" & @CRLF & _
"https://www.youtube.com/playlist?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r" & @CRLF & _
"https://www.youtube.com/embed/videoseries?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r " & @CRLF & _
"" & @CRLF & _
"http://xyz.com/v/abc" & @CRLF & _
"http://xyz.com/watch/?v=asd" & @CRLF & _
"http://xyz.com/embed/cCnrX1w5luM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")