import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:youtube\\.com.*(?:\\?|&)(?:v|list)=|youtube\\.com.*embed\\/|youtube\\.com.*v\\/|youtu\\.be\\/)((?!videoseries)[a-zA-Z0-9_]*)";
final String string = "https://www.youtube.com/watch?v=fqMfRi2gJok&index=1&list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r\n"
+ "https://www.youtube.com/watch?v=fqMfRi2gJok\n"
+ "http://youtu.be/cCnrX1w5luM \n"
+ "http://youtube.com/embed/cCnrX1w5luM\n"
+ "http://youtube.com/v/cCnrX1w5luM\n"
+ "https://www.youtube.com/playlist?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r\n"
+ "https://www.youtube.com/embed/videoseries?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r \n\n"
+ "http://xyz.com/v/abc\n"
+ "http://xyz.com/watch/?v=asd\n"
+ "http://xyz.com/embed/cCnrX1w5luM";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}