package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[+-]?[\d(x)]*[\^\d]*`)
var str = `-20^3+5x+10-50x^3 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}