$re = '/[+-]?[\d(x)]*[\^\d]*/';
$str = '-20^3+5x+10-50x^3 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);