const regex = /(deficient)(\s.*?\s)(exhibited)(\s.*?\s)(gmk)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(deficient)(\\s.*?\\s)(exhibited)(\\s.*?\\s)(gmk)', '')
const str = `deficient dhte wagdg sdfs exhibited vlskdv gmk
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}