const regex = /\s+style="[^"]+"/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+style="[^"]+"', 'mg')
const str = `<img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" alt="Johny" title="Johny" style="border: 0;">
<img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" style="border: 0;" alt="Johny" title="Johny">
<img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" alt="Johny" title="Johny">`;
const subst = `++`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);