import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\~\\![A-Za-z]+\\ start(?:(?:(?:\\(|,)\\ ?[\\w]+)*?\\))\\:\\{((?:(?!\\}\\:end\\n)[\\S\\s])+)(?:\\}\\:end)";
final String string = "~!data start(f1, f2, f3):{\n"
+ "abc '\\}:end'a\n"
+ "}:end\n\n"
+ "~!data start(f1, f2, f3):{\n"
+ "abc '\\}:end'a\n"
+ "}:end";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}