#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)^Content-(Disposition|Type).*name\s*=\s*"?([^.]*((\.|=2E)(" & @CRLF & _
"ade|adp|asp|bas|bat|chm|cmd|com|cpl|crt|dll|exe|" & @CRLF & _
"hlp|ht[at]|" & @CRLF & _
"inf|ins|isp|jse?|lnk|md[betw]|ms[cipt]|nws|" & @CRLF & _
"\{[[:xdigit:]]{8}(?:-[[:xdigit:]]{4}){3}-[[:xdigit:]]{12}\}|" & @CRLF & _
"ops|pcd|pif|prf|reg|sc[frt]|sh[bsm]|swf|" & @CRLF & _
"vb[esx]?|vxd|ws[cfh]))?)(\?=)?"?\s*(;|$)"
Local $sString = "Content-Disposition: attachment; filename=anythng.cmd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")