import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Content-(Disposition|Type).*name\\s*=\\s*\"?([^.]*((\\.|=2E)(\n"
+ "ade|adp|asp|bas|bat|chm|cmd|com|cpl|crt|dll|exe|\n"
+ "hlp|ht[at]|\n"
+ "inf|ins|isp|jse?|lnk|md[betw]|ms[cipt]|nws|\n"
+ "\\{[[:xdigit:]]{8}(?:-[[:xdigit:]]{4}){3}-[[:xdigit:]]{12}\\}|\n"
+ "ops|pcd|pif|prf|reg|sc[frt]|sh[bsm]|swf|\n"
+ "vb[esx]?|vxd|ws[cfh]))?)(\\?=)?\"?\\s*(;|$)";
final String string = "Content-Disposition: attachment; filename=anythng.cmd";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}